Caution: This documentation is for eZ Publish legacy, from version 3.x to 5.x.
For 5.x documentation covering Platform see eZ Documentation Center, for difference between legacy and Platform see 5.x Architecture overview.

Requirements

This page is outdated, see eZ Publish Platform 5.x requirements for your specific version http://doc.ez.no/display/EZP/Requirements 

  • eZ Publish 5.2 or higher running on legacy mode
  • Solr 3.6.1
  • Java Run-time Environment 5/1.5 or higher for Linux and Java Run-time Environment 6/1.6 or higher for Windows is mandatory
  • PHP Curl extension is recommended and mandatory for support
  • PHP posix and pcntl extensions are recommended to enable parallel indexing

Note: eZ Find includes an official version of Solr 3.6.1, but it can also run on any standard Solr 3.6.1 server provided by a third party (Linux distribution for instance). The only thing is to "inject" or merge the eZ Find schema.xml and solrconfig.xml with the third party Solr package.

Note #2: Since eZ Find is a legacy based extension only with eZ Publish running on legacy mode you will be able to use all features. If you'r not willing to run eZ Publish 5.2 on legacy mode, please check the online documentation for instructions on how to run legacy code.

Ricardo Correia (12/09/2013 3:33 pm)

André R. (07/04/2015 8:37 pm)

Ricardo Correia, André R.


Comments

  • optional requirements

    The php extensions posix et pcntl are needed to use multiple parallel subprocesses to index content.
    It is a good idea esp. to speed up initial indexation if the eZ Publish db is biggish.