Path

ez.no / documentation / ez publish / technical manual / 4.7 / installation / requirements / install notes for ez publis...


Caution: This documentation is for eZ Publish legacy, from version 3.x to 5.x.
For 5.x documentation covering Platform see eZ Documentation Center, for difference between legacy and Platform see 5.x Architecture overview.

Install notes for eZ Publish on RHEL 6

Red Hat Network

RHEL 6.1: The Certificate-based RHN

If upgrading from RHEL 6 to RHEL 6.1, you would like to use the new subscription system:
For a first-time certificate-based RHN registration:

  1. Run the command

    subscription-manager register
    
  2. Log into https://access.redhat.com/management/consumers/
    1. Click on the registered system in the consumer list
    2. Find the list of available subscriptions
    3. Subscribe to the relevant subscriptions
  3. Run the command

    subscription-manager subscribe --auto
    
  4. Run the command

    yum update
    

and all subscribed repos will be configured

With the certificate-based RHN, additional channels are not added through manual configuration. Additional rpm repositories are listed in /etc/yum.repos.d/redhat.repo, but are disabled by default. Yum install using the --enablerepo option and notice that the repositories may look different based on the installed product.

$ yum --enablerepo=rhel-6-server-optional-rpms install php-process

RHEL 6.0: The classic RHN

  • Log into Red Hat Network
  • Click on “Channels” in the menu bar.
  • Click “ Red Hat Optional Server 6”, “target systems” and enable this channel for your server

RHEL 6 and CentOS 6: EPEL

Some of the listed rpms are only available through EPEL. Extra Packages for Enterprise Linux (EPEL) is a Fedora Special Interest Group that creates, maintains, and manages a high quality set of additional packages for Enterprise Linux, including, but not limited to, Red Hat Enterprise Linux (RHEL), CentOS and Scientific Linux (SL).
http://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F

$ rpm -Uvh http://fedora.uib.no/epel/6/x86_64/epel-release-6-5.noarch.rpm

Best practice will be to disable EPEL by default and only enable for specific rpm installs with the yum option “--enablerepo=epel”. To disable it, set “enabled=0″ in “/etc/yum.repos.d/epel.repo”

Required RPMs

php-pear-Net-Curl

Required by ezfind

php-pear-Date

Red Hat's rpm for datetime

php-mbstring

Required by ezini

php-pecl-apc

The supported rpm equivalent to the pear install

php-process

Required for eZ scripts and cron jobs

php-mcrypt

 

php-xml

 

php-pgsql

PostgreSQL support

php-mysql

MySQL support

php-mbstring

Note: Available from the optional rpm channel

Geir Arne Waaler (09/06/2011 1:05 pm)

Geir Arne Waaler (24/01/2012 10:28 am)


Comments

There are no comments.