Navigation
eZ Documentation Center
 

This is outdated documentation made for eZ Publish Platform 5.2. It is being moved into the eZ Publish 5.x documentation, so please go there for most up-to-date documentation.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: gd and imageMagick EZP-22424

...

Updating Zetacomponents

As of eZ Publish 5.2, if you will use eZ Publish on legacy mode the Zetacomponents configuration must be updated.
For that you will need to install composer, which you can do by running one of the following command from you eZ Publish root folder:

If you have curl installed:

No Format
curl -sS https://getcomposer.org/installer | php

If you don't have curl installed:

No Format
php -r "eval('?>'.file_get_contents('https://getcomposer.org/installer'));"

After composer installed run the following command from the ezpublish_legacy/ folder:

No Format
php composer.phar install
Warning
titleVersion >= 5.2

ImageMagick and GD are both required to run the Composer installation.

 

Link assets

Info
The download file should already have generated these assets for you as of 5.2 / 2013.07, but in case of issues on Windows with symlinks within the download file, make sure to run these commands.

...