Global navigation

   Documentation Center
   eZ Studio & eZ Platform
     User Manual
     Technical Manual
     Glossary
   eZ Publish 4.x / legacy

 
eZ Publish (5.x)

eZ Publish 5.x | For eZ Platform & eZ Studio topics see Technical manual and User manual, for eZ Publish 4.x and Legacy topics see eZ Publish legacy

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Use composer for Symfony and its dependencies only, not for eZ Publish and it's dependencies.

Excerpt Include
glossary:Symfony
glossary:Symfony

 

For all

Before 5.

x versions

3 : Install Zetacomponents for a pure legacy setup
Status

colourYellow

title< 5.

x

3

As of eZ Publish 5.2, if you plan to use eZ Publish legacy only, as standalone (as in pointing apache to ezpublish_legacy folder or extracting only ezpublish_legacy), then Zetacomponents must be installed if you don't already have it via PEAR.

After Composer installation (see above for Composer installation instructions) run the following command from the ezpublish_legacy/ folder :

No Format
php composer.phar install
Note

Composer will need PHP extensions like GD/Imagemagic and Intl to run, see system requirements for further information.

 

Before 5.2 : Link assets
Status
title< 5.2

...